Помогите решить проблемку...

Программирование на Active Server Pages и VBScript.
Создатель
Постоялец
Постоялец
 
Сообщения: 422
Зарегистрирован: 21.04.2004 (Ср) 3:32
Откуда: Новосибирск

Помогите решить проблемку...

Сообщение Создатель » 05.09.2004 (Вс) 13:13

Помогите решить проблемку...
Пытаюсь создать asp.net web aplication средствами vb.net
так например добавляю на форму какой-нить textbox или button или любое другое...отправляю
ны выполнение...открывается окно ie , но страница абсолютна пуста....

если же вручную написать в коде формы какой-нить текст, то сам текст отображается нормально...
почему же тогда не отображаются объекты vb ???

Создатель
Постоялец
Постоялец
 
Сообщения: 422
Зарегистрирован: 21.04.2004 (Ср) 3:32
Откуда: Новосибирск

Сообщение Создатель » 06.09.2004 (Пн) 16:46

Ладно....раз никто не может понять почему это происходит, то может кто нить скажет что я делаю не так.....
Начну с начала....
На winXP ставлю весь iis
Ставлю vb.net . Запускаю vb. Создаю asp.net web aplication (средствами vb.net).
Появляется форма...запихиваю туда textbox ( из web forms)
нажимаю ctrl+F8 (build and browse) появляется совершенно пустаю страница.....
если же вместо textbox ( из web forms) вставляю что-нить их html то
все отображается......

MOV
Постоялец
Постоялец
 
Сообщения: 414
Зарегистрирован: 13.03.2004 (Сб) 15:13
Откуда: Санкт-Петербург

Сообщение MOV » 16.09.2004 (Чт) 16:54

Не помню, но поему в IIS, когда создаешь новую директорию для своих проектов (или используешь директорию по умолчанию), то надо открыть доступ к ней ASP_NET "юзера". В SQL-сервере - точно желательно проделать эту процедуру, а вот в IIS - не помню, но может в этом проблема? :?
Вобщем, посмотри inetmgr.exe.

MOV
Постоялец
Постоялец
 
Сообщения: 414
Зарегистрирован: 13.03.2004 (Сб) 15:13
Откуда: Санкт-Петербург

Сообщение MOV » 16.09.2004 (Чт) 17:05

А вероятнее всего тебе надо просто зайти в директорию ...\Microsoft.NET\Framework\ или в ...\Microsoft.NET\Framework\v1.0.3705 (не помню) и выполнить команду:
aspnet_regiis.exe /i или что-то такое, - поищи в инете там должно быть что-то 8) .
Как понимаю эта команда по сути и выполняет примерно то, о чем я сказал выше (хотя возможно в совсем обратном смысле :D, но суть от этого не менятеся, думаю должно помочь).

Создатель
Постоялец
Постоялец
 
Сообщения: 422
Зарегистрирован: 21.04.2004 (Ср) 3:32
Откуда: Новосибирск

Сообщение Создатель » 16.09.2004 (Чт) 20:35

Не помогает.....
Вообще то интересно...ведь не отображаются только
компоненты web forms ,а компоненты html отображаются
и вроде как iis работает с asp.net нормально (не считая этого глюка)

____________________________________________________________
У кого нить работает нормально asp.net ???
В смысле отображаются ли элементы из веб форм???
Если да, то напишите плиз вашу систему (что за винда и т.д.)
и ,если можно, как вы ставили vb.net ( в смысле сам процесс установки)
Заранее благодарю....

MOV
Постоялец
Постоялец
 
Сообщения: 414
Зарегистрирован: 13.03.2004 (Сб) 15:13
Откуда: Санкт-Петербург

Сообщение MOV » 17.09.2004 (Пт) 11:12

А сама команда-то проходит?
В общем, думаю, IIS будет работать с HTML, по любому, а вот c Framework, возможно, при определенных обстоятельствах требуется дополнительная настройка. Посмотри здесь http://runuo.q1.ru/controluo/faq.php
Что-то в этом духе.
Да еще как ты помещаешь их на форму (непосредственно из панели инструментов или кодом пытаешься сгенерить?)

Создатель
Постоялец
Постоялец
 
Сообщения: 422
Зарегистрирован: 21.04.2004 (Ср) 3:32
Откуда: Новосибирск

Сообщение Создатель » 17.09.2004 (Пт) 18:05

Огромное все спасибо!!!!!
Все заработало (правда с третьего запуска "../aspnet_regiis.exe /i "
Почему именно так, понять не могу....ну да ладно
Еще раз спасибо всем!!!!


Вернуться в ASP и VBScript

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

    TopList